Краткое руководство по сетевому лицензированию [Руководство по сетевому лицензированию Autodesk: ]

Установка Network License Manager
Краткое руководство по сетевому лицензированию

Организация сетевых лицензий для продуктов Autodesk требует тщательного планирования. В этом разделе предлагаются пошаговые инструкции по формированию среды лицензирования в сети. Изложение предполагает, что пользователь знаком с терминологией и процессами, необходимыми для успешной сетевой работы продуктов Autodesk. Тем, кто вообще не знаком с сетевым лицензированием, перед установкой и настройкой системы сетевых лицензий следует прочитать весь документ Руководство по сетевому лицензированию.

Темы в этом разделе

  • Установка Network License Manager
  • Установка и использование программы активации сетевой лицензии
  • Настройка сервера лицензий
  • Установка и использование SAMreport-Lite (не обязательно)
Отправьте ваши комментарии по поводу этой страницы


Установка Network License Manager [Руководство по сетевому лицензированию Autodesk: ]

Краткое руководство по сетевому лицензированию
Краткое руководство по сетевому лицензированию
Установка и использование программы активации сетевой лицензии
Установка Network License Manager

"Network License Manager" (Диспетчер сетевых лицензий) служит для настройки серверов лицензий и управления ими.

Для установки Network License Manager

  1. В обозревателе диска открыть вкладку "Install" (Установка).
  2. На вкладке "Установка" выбрать "Сетевое развертывание".
  3. В группе "Установка компонентов лицензирования" нажать ссылку "Network License Manager".
  4. На странице "Autodesk Network License Manager Setup" (Настройка Autodesk Network License Manager) нажать "Next" (Далее).
  5. На странице "License Agreement" (Лицензионный договор) прочесть лицензионный договор, установить флажок "I Accept" (Принимаю) и нажать "Далее".
    ЗамечаниеВ случае несогласия с условиями договора нужно нажать кнопку "Cancel" (Отмена) для отмены установки.
  6. На странице "Destination Folder" (Папка для установки) принять заданную по умолчанию папку или нажать кнопку "Browse" (Обзор) для указания иной папки для установки. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажать "Next" (Далее).
    Предупреждение Network License Manager не может быть установлен на сетевом диске. Папка для установки Network License Manager должна быть локальной. Необходимо явно указывать букву имени диска; формат универсального именования (UNC) не поддерживается.
  7. На странице "Ready to Install the Application" (Начало установки) нажать кнопку "Next" (Далее), чтобы перейти к копированию файлов на диск.
  8. Нажать "Finish" (Готово).


Установка и использование программы активации сетевой лицензии [Руководство по сетевому лицензированию Autodesk: ]

Установка Network License Manager
Краткое руководство по сетевому лицензированию
Настройка сервера лицензий
Установка и использование программы активации сетевой лицензии

Программа активации сетевой лицензии служит для получения лицензий через Интернет. Таким образом, экономятся время и силы, затрачиваемые на подготовку продукта Autodesk к работе в сетевой среде. Кроме того, утилита позволяет зарегистрировать продукт, получить поддержку по электронной почте (в случаях, когда не удается получить лицензию через Интернет), а также автоматически сохранять и переносить файлы с лицензиями.

Установка программы активации сетевой лицензии

  1. В обозревателе диска открыть вкладку "Install" (Установка).
  2. На вкладке "Установка" выбрать "Сетевое развертывание".
  3. В группе "Network License Components" (Установка компонентов лицензирования) нажать кнопкой мыши ссылку "Network License Activation Utility" (Программа активации сетевой лицензии).
  4. На [название продукта Autodesk] странице "Network License Activation Setup" (Установка программы активации сетевой лицензии) нажать "Next" (Далее).
  5. На странице "License Agreement" (Лицензионный договор) прочитать лицензионный договор, нажать кнопку "I accept" (Принимаю), а затем кнопку "Next" (Далее).
    ЗамечаниеВ случае несогласия с условиями договора нужно нажать кнопку "Cancel" (Отмена) для отмены установки.
  6. На странице "Destination Folder" (Папка для установки) принять заданную по умолчанию папку или нажать кнопку "Browse" (Обзор) для указания иной папки для установки. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажать "Next" (Далее).
  7. На странице "Ready to Install the Application" (Начало установки) нажать кнопку "Next" (Далее), чтобы установить программу активации сетевой лицензии.
  8. Нажать "Finish" (Готово).

Использование программы активации сетевой лицензии

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий" [image] [название продукта Autodesk] Network License Activation Utility (Программа активации сетевой лицензии).
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) ознакомиться с принципами работы утилиты и системными требованиями к ее использованию. Затем нажать "Next" (Далее).
  3. На странице "Server Information" (Сведения о сервере) ввести серийный номер продукта.
    Замечание В случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
  4. В разделе "License Server Model" (Модель сервера лицензий) выбрать модель сервера лицензий. Чтобы узнать подробнее об имеющихся вариантах модели, можно воспользоваться кнопкой с вопросительным знаком.
  5. В поле "Server Host Name" (Имя хоста) ввести имя хост-сервера или нажмите кнопку ["..."] для поиска имени сервера, который требуется использовать.
  6. Для каждого имени хоста, введенного на предыдущем этапе, заполнить поле "ID хоста" с помощью кнопки "Lookup" (Выбрать) или ввести значения вручную.
    Замечание Если на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Чтобы определить, какие адаптеры являются физическими, следует ввести ipconfig /all в строке ввода команд Windows и обратить внимание на поле "Описание" над каждым физическим адресом. Если физических сетевых адаптеров несколько, можно использовать любой из них; для этого необходимо, чтобы его имя выводилось в список командой ipconfig /all. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями не годятся.
  7. Если в пункте 4 было выбрано "Distributed Server" (Распределенный сервер), появляется поле "Seats" (Рабочие места). В поле "Seats" (Рабочие места) требуется ввести количество рабочих мест, обслуживаемых каждым сервером лицензий, а затем нажать кнопку "Next" (Далее).
  8. На странице "Confirm Server Information" (Подтвердить информацию сервера) проверить введенную вами информацию сервера и нажать кнопку "Next" (Далее).
  9. Если отобразится страница "Register and License Your Autodesk Product" (Регистрация продукта Autodesk и получение лицензии на него), выполнить все следующие действия, после чего нажать кнопку "Next" (Далее).
    • Для параметра "In the This Product Is To Be Registered To" (Регистрация продукта выполняется на) установить значение "Company" (Организация) или " Individual" (Частное лицо).
    • В поле "Select Country or Region" (Выберите страну или территорию) выбрать страну или территорию проживания.
    • Установить опцию "Is This an Upgrade" (Обновляется ли продукт с прежней версии) в положение "Yes" (Да) или "No" (Нет).
  10. Если отобразится страница "Registration Information" (Регистрационные данные), ввести пользовательские регистрационные данные и нажать "Next" (Далее).
  11. Если отобразится страница "Confirm Information" (Подтверждение данных), проверить регистрационные данные и нажать "Next" (Далее).
  12. Если отобразится страница "Connecting" (Связь с Интернетом) нажать "Next" (Далее), чтобы подключиться к Интернету и получить сетевую лицензию.
  13. На странице "Licenses Received" (Полученные лицензии) в поле "Save License File for [computer name] "(Сохранить файл лицензий для <имя компьютера>) указать папку для сохранения файла лицензии или нажать "Browse" (Обзор) для выбора места сохранения.
    Замечание Рекомендуется сохранять файл лицензий в той же папке, в которой был установлен Network License Manager.
  14. Если уже имеется файл лицензий от другого продукта Autodesk, выбрать один из следующих вариантов:
    • Вставить информацию о новой лицензии в него. Добавление сведений о новой лицензии в существующий файл лицензий.
    • Заменить существующий файл лицензий. Полная замена содержимого существующего файла лицензий сведениями о новой лицензии. Этот параметр следует выбирать только в том случае, если все остальные лицензии в файле действительно больше не нужны.
  15. Нажать "Next" (Далее).
  16. На странице "License Activation Successful" (Активация лицензии успешно выполнена) нажать кнопку "Print" (Печать), чтобы вывести информацию о лицензии на печать, либо нажать "Done" (Готово) для завершения групповой операции и выхода из программы активации сетевой лицензии.


Настройка сервера лицензий [Руководство по сетевому лицензированию Autodesk: ]

Установка и использование программы активации сетевой лицензии
Краткое руководство по сетевому лицензированию
Установка и использование SAMreport-Lite (не обязательно)
Настройка сервера лицензий

Настройка сервера лицензий осуществляется таким образом, чтобы можно было управлять лицензиями на продукт Autodesk, полученными с помощью программы активации сетевой лицензии. Для настройки параметров сервера используется утилита lmtools.exe.

Для настройки параметров сервера лицензий

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий Autodesk" [image] LMTOOLS.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы Lmtools установить переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Перейти на вкладку "Config Services" (Настроить службы).
  4. На вкладке "Config Services" (Настроить службу) в списке "Service Name" (Имя службы) выбрать службу или выполнить одно из следующих действий:
    • Убедиться, что в списке выбрана именно та служба, которую предполагается использовать для управления лицензиями.
    • Если список пуст, ввести имя службы, которую предполагается использовать для управления лицензиями.
    ЗамечаниеЕсли установлены несколько программных продуктов различных поставщиков, которые для управления лицензиями используют технологию FLEXlm®, список "Наименование службы" содержит несколько служб.
  5. В поле "Path to Lmgrd.exe File" (Путь к файлу Lmgrd.exe)задать путь к демону Network License Manager (lmgrd.exe), или найти его с помощью кнопки "Browse" (Обзор).

    По умолчанию этот демон устанавливается в папку \Program Files\Autodesk Network License Manager.

  6. В поле "Path to the License File" (Путь к файлу лицензий) ввести путь к файлу лицензий или найти его с помощью кнопки "Browse" (Обзор).
  7. В поле "Path to the Debug Log File" (Путь к файлу отладочного журнала) ввести путь, по которому формируется отладочный журнал, или найти с помощью кнопки "Browse" (Обзор) существующий журнал.
  8. Для запуска lmgrd.exe в качестве службы установить флажок "Use Services".
  9. Для автоматической загрузки lmgrd.exe при запуске системы установить флажок "Start Server at Power Up".
  10. Для сохранения настроек с именем, заданным в пункте 4, нажать кнопку "Save Service" (Сохранить службу). Затем нажать "Да".
  11. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) выполнить одно из следующих действий:
    • Если службы для продуктов Autodesk еще не созданы, нажать кнопку "Start Server" (Запустить сервер) для запуска сервера лицензий.
    • Если служба для продукта Autodesk уже создана и запущена, нажать кнопку "ReRead" (Прочитать еще раз) для обновления Network License Manager всеми внесенными в файл лицензий или параметров изменениями.

      Сервер лицензий запускается и готов обрабатывать запросы клиентов.

  12. Закрыть lmtools.exe.


Установка и использование SAMreport-Lite (не обязательно) [Руководство по сетевому лицензированию Autodesk: ]

Настройка сервера лицензий
Краткое руководство по сетевому лицензированию
Введение в принципы сетевого лицензирования
Установка и использование SAMreport-Lite (не обязательно)

SAMreport-Lite - это инструмент для составления отчетов, помогающий отслеживать использование сетевых лицензий. Технология SAMreport-Lite компании Macrovision Corporation позволяет отслеживать использование клиентами программного обеспечения, для управления лицензиями на которое используется FLEXlm®.

Дополнительную информацию об установке и использовании SAMreport-Lite см. в документе Руководство пользователя SAMreport-Lite, доступ к которому можно получить из справочной системы продукта Autodesk или с помощью вкладки "Documentation" (Документация) обозревателя диска.


Введение в принципы сетевого лицензирования [Руководство по сетевому лицензированию Autodesk: ]

Установка и использование SAMreport-Lite (не обязательно)
Диспетчер сетевых лицензий (Network License Manager)
Введение в принципы сетевого лицензирования

Инструментами сетевого лицензирования для продуктов Autodesk являются диспетчер сетевых лицензий, программа активации сетевой лицензии, средства настройки FLEXlm и SAMreport-Lite. Описание каждого инструмента приведено в следующих разделах.

Темы в этом разделе

  • Диспетчер сетевых лицензий (Network License Manager)
  • Программа активации сетевой лицензии
  • Средства настройки FLEXlm
  • Инструмент составления отчетов о лицензиях SAMreport-Lite


Диспетчер сетевых лицензий (Network License Manager) [Руководство по сетевому лицензированию Autodesk: ]

Введение в принципы сетевого лицензирования
Введение в принципы сетевого лицензирования
Системные требования для установки Network License Manager
Диспетчер сетевых лицензий (Network License Manager)

Программа Network License Manager (Диспетчер сетевых лицензий) используется в процессе установки и развертывания сетевых версий продуктов Autodesk®. Вместе с мастером сетевой установки он отвечает за установку продукта Autodesk и управляет распределением лицензий в сети. Network License Manager служит для настройки серверов лицензий и управления ими. С помощью мастера сетевой настройки можно управлять развертыванием продукта Autodesk в сети.

Дополнительную информацию о развертывании продуктов Autodesk в сети см. в Руководстве сетевого администратора, доступ к которому возможен из обозревателя диска программных продуктов Autodesk или справочной системы продукта.

Темы в этом разделе

  • Системные требования для установки Network License Manager


Системные требования для установки Network License Manager [Руководство по сетевому лицензированию Autodesk: ]

Диспетчер сетевых лицензий (Network License Manager)
Диспетчер сетевых лицензий (Network License Manager)
Программа активации сетевой лицензии
Системные требования для установки Network License Manager

Сервер лицензий должен удовлетворять минимальным требованиям к рекомендуемой конфигурации системы. Предъявляемые к системе требования изложены в следующей таблице.

Требования к аппаратным средствам и программному обеспечению сервера лицензий
Элемент | Требования | Замечания
Операционная система | Windows 2003 Server Edition WIndows XP Professional Windows 2000 Server Edition Windows 2000 с пакетом обновления 4 | Network License Manager поддерживает только сети Ethernet. Конфигурация с резервными серверами лицензий поддерживается только в операционных системах Windows2000 Server Edition и Windows 2003 Server.
Компьютер/процессор | Pentium III или выше 450 МГц (минимум) |
Сетевой адаптер | По меньшей мере, один активный физический адаптер Ethernet |
Коммуникационный протокол | TCP/IP | Network License Manager работает с пакетами типа TCP.


Программа активации сетевой лицензии [Руководство по сетевому лицензированию Autodesk: ]

Системные требования для установки Network License Manager
Введение в принципы сетевого лицензирования
Средства настройки FLEXlm
Программа активации сетевой лицензии

Программа активации сетевой лицензии служит для получения лицензий через Интернет. Таким образом, экономятся время и силы, затрачиваемые на подготовку продукта Autodesk к работе в сетевой среде. Утилита также упрощает или автоматизирует задачи, которые выполнялись вручную в предыдущих версиях программных продуктов Autodesk.

Кроме того, утилита отвечает за регистрацию программного продукта, обеспечивает автоматическое формирование сообщений электронной почты в случае отсутствия возможности получить лицензию в реальном времени через Интернет, а также автоматически сохраняет и перемещает файлы лицензий.

Замечание Для получения файла лицензии рекомендуется использовать программу активации сетевой лицензии. Если возможность выхода в Интернет для получения файла лицензии отсутствует, см. Получение имени и идентификатора хоста вручную.


Средства настройки FLEXlm [Руководство по сетевому лицензированию Autodesk: ]

Программа активации сетевой лицензии
Введение в принципы сетевого лицензирования
Обновление предыдущей версии FLEXlm
Средства настройки FLEXlm

В диспетчере сетевых лицензий для управления сетевыми лицензиями используется технология FLEXlm® компании Macrovision Corporation. FLEXlm предоставляет средства администрирования, которые позволяют упростить управление сетевыми лицензиями. Средства FLEXlm можно использовать для просмотра статуса сетевых лицензий, восстановления лицензий, потерянных вследствие сбоев системы, устранения ошибок на серверах лицензий, а также обновления существующих файлов лицензий.

Темы в этом разделе

  • Обновление предыдущей версии FLEXlm
  • Утилиты для управления сервером лицензий
  • Файл параметров


Обновление предыдущей версии FLEXlm [Руководство по сетевому лицензированию Autodesk: ]

Средства настройки FLEXlm
Средства настройки FLEXlm
Утилиты для управления сервером лицензий
Обновление предыдущей версии FLEXlm

Для продуктов на базе AutoCAD 2007 требуется FLEXlm версии 10.8 или выше. Если на компьютере установлена версия FLEXlm ниже 10.8, необходимо обновить ее до версии 10.8 или выше.

Для определения того, какая версия FLEXlm установлена на компьютере, необходимо проверить версию трех следующих файлов:

  • lmgrd.exe
  • lmtools.exe
  • adskflex.exe
Замечание Если на сервере, на который планируется установить диспетчер сетевых лицензий Autodesk, уже имеются средства настройки FLEXlm для другого программного продукта, необходимо убедиться, что используется самая последняя версия lmgrd.exe.

Для проверки версии файлов lmutil.exe, lmtools.exe и adskflex.exe

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий" [image] LMTOOLS.
  2. В lmtools.exe перейти на вкладку "Utility" (Программы).
  3. На вкладке "Utility" (Программы) ввести путь к файлу или нажать кнопку "Browse" (Обзор), найти файл и нажать "Open" (Открыть). Путь к файлу должен выглядеть подобно следующему:

    C:\Program Files\Autodesk Network License Manager\lmutil.exe

  4. На вкладке "Utility" (Программы) выбрать "Find Version" (Найти версию).

    На экране отобразится версия выбранного файла. Если необходимо обновить версию FLEXlm, см. Обновление FLEXlm .

Обновление FLEXlm

  1. Создать резервные копии файлов лицензий.
  2. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий" [image] LMTOOLS.
  3. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажать кнопку "Stop Server" (Остановить сервер).
  4. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) нажать кнопку "Stop Server" (Остановить сервер).
  5. Закрыть lmtools.exe.
  6. Удалить Network License Manager. Более подробную информацию об удалении Network License Manager см. в Удаление Network License Manager.
  7. Установить Network License Manager. Более подробную информацию об установке Network License Manager, см. в Установка Autodesk Network License Manager.
Замечание Версия 10.8 диспетчера лицензий FLEXlm, которая поставляется вместе с программными продуктами на основе AutoCAD 2007, совместима с более ранними версиями и управляет лицензиями для продуктов Autodesk версий 2006, 2005, 2004 и 2002.


Утилиты для управления сервером лицензий [Руководство по сетевому лицензированию Autodesk: ]

Обновление предыдущей версии FLEXlm
Средства настройки FLEXlm
Файл параметров
Утилиты для управления сервером лицензий

Для управления сервером лицензий FLEXlm предоставляет две утилиты. Эти программы хранятся в папке [имя продукта Autodesk]\ Program Files\Диспетчер сетевых лицензий Autodesk.

  • lmtools.exe. Утилита управления сервером лицензий, обладающая графическим пользовательским интерфейсом Microsoft® Windows.
  • lmutil.exe. Утилита управления сервером лицензий, имеющая интерфейс командной строки.

Утилиты lmtools.exe и lmutil.exe используются для решения следующих задач по управлению сервером лицензий:

  • Запуск, остановка работы и перезапуск сервера.
  • Настройка, обновление и повторный запуск файла лицензий.
  • Диагностирование системы и проблем с лицензированием.
  • Просмотр статуса сервера, включая статус лицензий.


Файл параметров [Руководство по сетевому лицензированию Autodesk: ]

Утилиты для управления сервером лицензий
Средства настройки FLEXlm
Инструмент составления отчетов о лицензиях SAMreport-Lite
Файл параметров

Другим компонентом FLEXlm является файл параметров. С помощью этого файла можно настраивать специальные параметры. Подробнее о создании и использовании файлов параметров см. Настройка и использование файла параметров.

Файл параметров используется для настройки следующих параметров сервера:

  • "Report log file" (Отчет об использовании лицензий). Создание сжатого зашифрованного файла отчета об использовании лицензий с помощью SAMreport-Lite. Дополнительную информацию о SAMreport-Lite см. в Руководстве пользователя SAMreport-Lite, доступ к которому можно получить с помощью вкладки "Документация" обозревателя диска.
  • Заимствование лицензий. Если продукт Autodesk поддерживает заимствование лицензий, пользователям разрешено заимствовать лицензии с сервера и работать с продуктом локально, без подключения к серверу лицензий. Лицензия заимствуется на ограниченный период времени.
  • Тайм-аут лицензии. На сервере лицензий можно задать тайм-аут. Благодаря этой функции при потере связи с рабочей станцией, или если лицензия забрана, а продукт Autodesk не используется на рабочей станции дольше заданного для тайм-аута времени, лицензия автоматически возвращается на сервер лицензий.

Подробнее о параметрах настройки см. Настройка сервера лицензий.

Дополнительную информацию об использовании FLEXlm см. в документации по FLEXlm, находящейся в папке C:\Program Files\Диспетчер сетевых лицензий Autodesk\Docs\FlexUser\TOC.htm.


Инструмент составления отчетов о лицензиях SAMreport-Lite [Руководство по сетевому лицензированию Autodesk: ]

Файл параметров
Введение в принципы сетевого лицензирования
Выбор модели лицензирования
Инструмент составления отчетов о лицензиях SAMreport-Lite

Версия SAMreport, называемая SAMreport-Lite, не включена в установку, но с ее помощью можно отслеживать сетевые лицензии. Технология SAMreport-Lite компании Macrovision Corporation позволяет отслеживать использование клиентами программного обеспечения, для управления лицензиями на которое используется FLEXlm.

SAMreport-Lite позволяет формировать отчеты об использовании лицензий в различных форматах, включая HTML-формат, текстовый формат и формат Report Interchange. Дополнительную информацию о SAMreport-Lite, в том числе инструкции по установке этого средства, см. в Руководстве пользователя SAMreport-Lite.

Замечание Установить SAMreport-Lite, а также ознакомиться с Руководством пользователя SAMreport-Lite можно с помощью обозревателя диска продукта Autodesk.

Для получения дополнительной информации о SAMreport-Lite, а также обновлений этой программы посетите веб-узел Autodesk по адресу:

www.autodesk.com/samreportlite


Выбор модели лицензирования [Руководство по сетевому лицензированию Autodesk: ]

Инструмент составления отчетов о лицензиях SAMreport-Lite
Выбор конфигурации серверов лицензий
Выбор модели лицензирования

В этом разделе представлена информация, которую требуется знать до начала установки сервера сетевых лицензий. В этом разделе содержится информация о поддерживаемых моделях сервера лицензий, о действии и наличии лицензии, а также определения и параметры, примеры файлов лицензий, типы и варианты поведения лицензий, а также сведения о тактовом сигнале сервера лицензий.

Темы в этом разделе

  • Выбор конфигурации серверов лицензий
  • Сведения о лицензиях


Выбор конфигурации серверов лицензий [Руководство по сетевому лицензированию Autodesk: ]

Выбор модели лицензирования
Выбор модели лицензирования
Конфигурация с одним сервером лицензий
Выбор конфигурации серверов лицензий

Прежде всего, необходимо выбрать модель конфигурации сервера лицензий для управления лицензиями на продукт Autodesk®. Autodesk поддерживает следующие модели конфигурации серверов лицензий:

  • Конфигурация с одним сервером лицензий
  • Конфигурация с несколькими серверами лицензий
  • Конфигурация с резервными серверами лицензий

Темы в этом разделе

  • Конфигурация с одним сервером лицензий
  • Конфигурация с несколькими серверами лицензий
  • Конфигурация с резервными серверами лицензий


Конфигурация с одним сервером лицензий [Руководство по сетевому лицензированию Autodesk: ]

Выбор конфигурации серверов лицензий
Выбор конфигурации серверов лицензий
Конфигурация с несколькими серверами лицензий
Конфигурация с одним сервером лицензий

В модели с одним сервером лицензий Network License Manager устанавливается на одном сервере, на котором и осуществляется вся деятельность по управлению лицензиями. Все лицензии, доступные на сервере, представлены в едином файле лицензий.

Преимущества конфигурации с одним сервером лицензий

  • Поскольку управление лицензиями осуществляется на одном сервере, то пункт администрирования и источник возможных сбоев сосредоточены в одном месте.
  • Из всех трех моделей серверов лицензий такая конфигурация наиболее проста в обслуживании.

Недостатки конфигурации с одним сервером лицензий

  • При сбое единственного сервера лицензий работа с продуктом Autodesk становится невозможной до устранения неполадок.


Конфигурация с несколькими серверами лицензий [Руководство по сетевому лицензированию Autodesk: ]

Конфигурация с одним сервером лицензий
Выбор конфигурации серверов лицензий
Конфигурация с резервными серверами лицензий
Конфигурация с несколькими серверами лицензий

В модели с несколькими серверами источники лицензий распределены в сети. Для каждого сервера необходим собственный уникальный файл лицензий. Для создания распределенного сервера лицензий необходимо запустить Network License Manager на каждом из серверов, входящих в распределенный серверный пул.

Преимущества конфигурации с несколькими серверами лицензий

  • Серверы могут работать в территориально распределенных сетях (WAN). Нахождения в единой подсети от них не требуется.
  • При сбое одного из серверов распределенного пула лицензии на остальных серверах остаются доступными.
  • Конфигурация с несколькими серверами лицензий поддерживается для Windows XP® Professional и на рабочих станциях и серверах Windows® 2000 и Windows 2003 Server.
  • Для замены одного из серверов в распределенном пуле нет необходимости перестраивать весь пул.
  • Замена серверов осуществляется проще, чем в модели с резервными серверами, где для этого необходимо возобновить работу всего пула.

Недостатки конфигурации с несколькими серверами лицензий

  • При сбое одного из серверов распределенного пула лицензии на нем становятся недоступными.


Конфигурация с резервными серверами лицензий [Руководство по сетевому лицензированию Autodesk: ]

Конфигурация с несколькими серверами лицензий
Выбор конфигурации серверов лицензий
Сведения о лицензиях
Конфигурация с резервными серверами лицензий

В конфигурации с резервными серверами лицензий для работы с одним и тем же файлом лицензий можно использовать три сервера, один из которых основной, а два других являются резервными и используются при сбое основного сервера. В этой конфигурации выдача лицензий не прекращается, если функционируют хотя бы два из этих трех серверов. Файл лицензий одинаков на всех трех серверах. На каждом из серверов необходимо установить Network License Manager.

В конфигурации с резервными серверами лицензий необходимо, чтобы все серверы находились в одной подсети и имели надежное соединение. Серверы с медленным, неустойчивым или коммутируемым соединением не поддерживаются.

Преимущества конфигурации с резервными серверами лицензий

  • При сбое одного из трех серверов все лицензии, управляемые распределенным пулом, остаются доступными.

Недостатки конфигурации с резервными серверами лицензий

  • Если сбои произошли более чем на одном сервере, все лицензии становятся недоступными.
  • Все три сервера должны входить в одну подсеть и иметь надежные сетевые связи. Конфигурация с резервными серверами неустойчива при повреждениях в сети.
  • Конфигурация с резервными серверами поддерживается только в операционных системах Windows 2000 Server Edition и Windows 2003 Server Edition. Конфигурация с резервными серверами не поддерживается в операционных системах Windows XP и Windows 2000.
  • При замене любого из трех серверов необходимо перестроить весь пул серверов.
  • Если установленный на компьютере продукт Autodesk поддерживает заимствование лицензий и лицензии заимствуются с пула резервного сервера лицензий, после останова Network License Manager необходимо перезапустить сервер лицензий.


Сведения о лицензиях [Руководство по сетевому лицензированию Autodesk: ]

Конфигурация с резервными серверами лицензий
Выбор модели лицензирования
Действия с лицензиями и свободные лицензии
Сведения о лицензиях

В данном разделе приводятся сведения о работе и доступности лицензий, о файле лицензий, типах и видах лицензий и о тактовом сигнале.

Темы в этом разделе

  • Действия с лицензиями и свободные лицензии
  • Файлы лицензий
  • Примеры файлов лицензий
  • Примеры пакетных файлов лицензий
  • Типы и виды лицензий
  • Тактовый сигнал


Действия с лицензиями и свободные лицензии [Руководство по сетевому лицензированию Autodesk: ]

Сведения о лицензиях
Сведения о лицензиях
Файлы лицензий
Действия с лицензиями и свободные лицензии

При открытии продукта Autodesk на рабочей станции программа определяет, к какому из серверов лицензий следует обратиться за лицензией. После этого продукт запрашивает на сервере лицензию по сетевому протоколу TCP/IP.

Если количество свободных лицензий не исчерпано, то Network License Manager выдает лицензию для рабочей станции. После этого на рабочей станции запускается сеанс продукта, а число свободных лицензий на сервере сокращается на единицу.

Аналогичным образом, по окончании работы одного пользователя с продуктом Network License Manager освобождает лицензию для другого пользователя. Параллельные сеансы продукта Autodesk на одном компьютере используют только одну лицензию. При закрытии последнего из таких параллельных сеансов лицензия высвобождается.

За управление распределением и наличием свободных лицензий отвечают следующие три процесса:

  • Демон диспетчера лицензий (lmgrd.exe). Этот процесс осуществляет первичное соединение с приложением, а затем устанавливает соединение с демоном поставщика. Демон lmgrd.exe используется исключительно для связи с демоном поставщика. Он не устанавливает подлинность лицензий и не распределяет их. Он просто передает запросы пользователей демону поставщика. Такой подход обеспечивает возможность использования одного демона диспетчера лицензий lmgrd.exe для выдачи лицензий по различным программным продуктам. Демон lmgrd.exe запускает и перезапускает по мере необходимости демон поставщика.
  • Демон поставщика Autodesk (adskflex.exe). Демон поставщика постоянно следит за выданными лицензиями и рабочими станциями, на которых они используются. Для каждого поставщика программного обеспечения имеется свой демон поставщика, отвечающий за управление лицензиями программ именно этого поставщика. Как следует из наименования, adskflex.exe - это демон поставщика, отвечающий за лицензирование только программных продуктов фирмы Autodesk.
Замечание Если демон поставщика adskflex.exe по каким-либо причинам прекращает работу, все пользователи утрачивают свои лицензии, пока демон диспетчера лицензий lmgrd.exe вновь не запустит демона поставщика или не будут устранены неполадки, вызвавшие прекращение работы демона поставщика.
  • Файл лицензий. Текстовый файл, в котором содержится информация о лицензиях, специфичная для каждого поставщика программного обеспечения.


Файлы лицензий [Руководство по сетевому лицензированию Autodesk: ]

Действия с лицензиями и свободные лицензии
Сведения о лицензиях
Примеры файлов лицензий
Файлы лицензий

Полученный вами от компании Autodesk файл сетевых лицензий содержит лицензионную информацию, необходимую для установки в сети. Эти данные покупатель получает при регистрации продукта Autodesk.

Файл лицензий содержит информацию об узлах сетевых серверов и о демонах поставщика. Он также содержит шифрованную цифровую подпись, созданную при генерации файла в компании Autodesk.

Файл лицензий располагается в папке с общим доступом, которая указывается пользователем в Мастере развертывания. Доступ к папке должен быть открыт для каждого пользователя, который запускает продукт, установленный в сети.

В следующей таблице приведено описание параметров в файле лицензий.

Параметры в файле лицензий

Строка

Параметр

Пояснение

Пример

SERVER

Имя хоста

Имя хоста сервера, где установлен Network License Manager

labserver

Идентификатор хоста

Ethernet-адрес сервера, где установлен Диспетчер сетевых лицензий

03D054C0149B

USE_SERVER

[Нет]

VENDOR

Демон поставщика

Имя серверного демона поставщика фирмы Autodesk.

adskflex.exe

Номер порта

Сетевой порт, зарезервированный и предназначенный только для работы с программными продуктами Autodesk, запускающими демон поставщика фирмы Autodesk

port=2080

PACKAGE

Имя

Имя группы кодов продукта

SERIES_1

Демон поставщика

Имя серверного демона поставщика фирмы Autodesk.

adskflex.exe

Версия

Внутренний номер версии

1.000

COMPONENTS

Список кодов продукта, содержащихся в пакете

COMPONENTS= "526000REVIT_9_OF\ 51200ACD_2007_OF\ 513001INVBUN_11_OF"

OPTIONS

OPTIONS=SUITE

SUPERSEDE

Замена всех существующих строк INCREMENT с тем же кодом продукта во всех файлах лицензий на том же сервере лицензий, если в них указана более ранняя дата генерации

SUPERSEDE

Дата генерации

Дата выпуска лицензии

ISSUED=15-jul-2006

SIGN

Зашифрованная цифровая подпись, используемая для подтверждения подлинности файла лицензий.

SIGN=0 SIGN2=0

INCREMENT

Код продукта

Продукт, для которого используется файл лицензий

Если в файле лицензии имеется параметр INCREMENT PLIST, он определяет приоритет использования лицензии, если такой же код продукта имеется в строке INCREMENT.

Более подробную информацию см. в

Пример дополнительных параметров файла лицензий

51200ACD_2007_0F

Демон поставщика

Имя серверного демона поставщика фирмы Autodesk.

adskflex.exe

Версия

Внутренний номер версии

1.000

Срок действия

Срок действия лицензий

постоянный

Число лицензий

Число лицензий, предусмотренных в файле лицензий

25

VENDOR_STRING

Тип использования и поведение лицензии продукта, поддерживаемые файлом лицензии.

Параметр VENDOR_STRING в строке INCREMENT PLIST определяет порядок использования лицензий на основе списка кодов продукта.

Более подробную информацию см. в Пример дополнительных параметров файла лицензий.

COMMERCIAL

SUPERSEDE

Замена всех существующих строк INCREMENT с тем же кодом продукта во всех файлах лицензий на том же сервере лицензий, если в них указана более ранняя дата генерации

SUPERSEDE

BORROW

Определение периода заимствования для тех лицензий, которые описаны в одной и той же строке INCREMENT.

Для данного примера максимальный срок заимствования лицензий составляет 4320 часов (180 дней), если не указан иной срок (например, BORROW=2880 означает, что лицензии могут быть заимствованы не более чем на 2880 часов, т.е. 120 дней)

Если данный параметр отсутствует в файле лицензий, возможность заимствования лицензий отключается

BORROW=4320

DUP_GROUP

Определение множественных запросов лицензий при использовании лицензии одним и тем же пользователем на одном и том же компьютере

DUP_GROUP=UH

ISSUED

Дата создания файла лицензии

в Autodesk

15-jul-2006

Серийный номер

Серийный номер программного продукта Autodesk.

123-12345678

SIGN

Зашифрованная цифровая подпись, используемая для подтверждения подлинности файла лицензий.

SIGN=6E88EFA8D44C


Примеры файлов лицензий [Руководство по сетевому лицензированию Autodesk: ]

Файлы лицензий
Сведения о лицензиях
Пример файла лицензий, не привязанного к определенному продукту
Примеры файлов лицензий

Примеры файлов лицензий приводятся в данном документе для пояснения работы файлов лицензий в определенной сетевой среде. Компания Autodesk предоставляет стандартный файл лицензий для отдельных продуктов и файл лицензий с дополнительными парметрами для продуктов, которые продаются как в составе пакета продуктов, так и отдельно.

  • Стандартный файл лицензий. Если пользователь приобретает один или несколько продуктов, которые не входят в комплект поставки пакета продуктов, он получит стандартный файл лицензий.
  • Стандартный файл лицензий с дополнительными параметрами.Если пользователь приобретает продукты Autodesk, которые поставляются в составе пакета продуктов, а также продаются отдельно, он получит стандартный файл лицензий с дополнительными параметрами. Дополнительные параметры определяют последовательность использования лицензции, при этом лицензия на отдельный продукт используется ранее лицензии на пакет продуктов.

В составе примеров файлов лицензий Autodesk имеются файл лицензий, не связанный с конкретным продуктом, полные файлы лицензий для конфигурации с одним сервером, с несколькими серверами и с резервным сервером, комбинированный файл лицензий на различные версии продуктов, а также пример добавления дополнительных параметров к стандартному файлу лицензий.

Темы в этом разделе

  • Пример файла лицензий, не привязанного к определенному продукту
  • Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий
  • Пример файла лицензий для конфигурации с резервными серверами лицензий
  • Пример комбинированного файла лицензий для различных версий продуктов Autodesk
  • Пример дополнительных параметров файла лицензий


Пример файла лицензий, не привязанного к определенному продукту [Руководство по сетевому лицензированию Autodesk: ]

Примеры файлов лицензий
Примеры файлов лицензий
Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий
Пример файла лицензий, не привязанного к определенному продукту

Далее приводится пример содержания файла лицензий с параметрами, связанными с каждой из строк:

SERVER Имя_сервера ID_хоста

USE_SERVER

VENDOR adskflex port=portnumber

INCREMENT код_продукта Adskflex Номер_версии Срок_действия \

Число_лицензий \

VENDOR_STRING=Тип_использования:Поведение BORROW=4320 SUPERSEDE \ DUP_GROUP=DupGrp ISSUED=Дата_выпуска SN=Серийный_номер \

SIGN=


Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий [Руководство по сетевому лицензированию Autodesk: ]

Пример файла лицензий, не привязанного к определенному продукту
Примеры файлов лицензий
Пример файла лицензий для конфигурации с резервными серверами лицензий
Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий

Полный файл лицензий для конфигурации с одним сервером или конфигурации с несколькими серверами лицензий может выглядеть, например, следующим образом:

SERVER Server2 2a34567f90d3

USE_SERVER

VENDOR adskflex port=2080

INCREMENT 51200ACD_2007_0F adskflex 1.000 permanent 3 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=UH ISSUED=15-jul-2006 SN=123-12345678 SIGN="1707 \

9EAC CBCB 2405 692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 \

5A1B 4A44 083A BE5F 3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E \

3EBD 0B48 4E75 193A DA82" SIGN2="004A FC90 AB47 3F6B 59BC \

6681 6971 A76A BA52 98E2 5671 26B3 0E78 791B 109F 0591 7DC3 \

F09F 4D8D 4FB7 E341 4A03 CD68 1D77 27F8 8555 9CF7 9380"


Пример файла лицензий для конфигурации с резервными серверами лицензий [Руководство по сетевому лицензированию Autodesk: ]

Пример файла лицензий для конфигурации с одним или несколькими серверами лицензий
Примеры файлов лицензий
Пример комбинированного файла лицензий для различных версий продуктов Autodesk
Пример файла лицензий для конфигурации с резервными серверами лицензий

Полный файл лицензий для конфигурации с резервными серверами лицензий может выглядеть, например, следующим образом:

SERVER Server1 1a34567c90d2 27005

SERVER Server2 2a34567f90d3 27005

SERVER Server3 3a34567b90d4 27005

USE_SERVER

VENDOR adskflex port=2080

INCREMENT 51200ACD_2007_0F adskflex 1.000 permanent 3 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=UH ISSUED=15-jul-2006 SN=123-12345678 SIGN="1707 \

9EAC CBCB 2405 692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 \

5A1B 4A44 083A BE5F 3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E \

3EBD 0B48 4E75 193A DA82" SIGN2="004A FC90 AB47 3F6B 0E6D \

6681 6971 A76A BA52 98E2 5671 26B3 0E78 791B 109F 0591 7DC3 \

F09F 4D8D 4FB7 E341 4A03 CD68 1D77 27F8 8555 9CF7 DEDD 9380"

ЗамечаниеВ конфигурации с резервными серверами необходимо задавать номер порта (по умолчанию 27005) для каждого сервера.


Пример комбинированного файла лицензий для различных версий продуктов Autodesk [Руководство по сетевому лицензированию Autodesk: ]

Пример файла лицензий для конфигурации с резервными серверами лицензий
Примеры файлов лицензий
Пример дополнительных параметров файла лицензий
Пример комбинированного файла лицензий для различных версий продуктов Autodesk

Один файл лицензий может использоваться для различных версий одного и того же продукта Autodesk и запускать все эти продукты с одним сервером лицензий. Например, можно скомбинировать файл лицензий для AutoCAD 2007 с файлами лицензий для AutoCAD и AutoCAD Map.

Комбинированный файл лицензий может иметь, например, следующий вид:

SERVER Servername HostID

USE_SERVER

VENDOR adskflex port=2080

INCREMENT 42600ACD_2004_0F adskflex 1.000 permanent 3 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=UH ISSUED=22-jun-2003 SN=123-12345678 \

SIGN=6E88EFA8D44C

INCREMENT 51200ACD_2007_0F adskflex 1.000 permanent 3 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=UH ISSUED=15-jul-2006 SN=123-12345678 SIGN="1707 \

9EAC CBCB 2405 692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 \

5A1B 4A44 083A BE5F 3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E \

3EBD 0B48 4E75 193A DA82" SIGN2="004A FC90 AB47 3F6B 59BC \

6681 6971 A76A BA52 98E2 5671 26B3 0E78 791B 109F 0591 7DC3 \

F09F 4D8D 4FB7 E341 4A03 CD68 1D77 27F8 8555 9CF7 DEDD 9380"

INCREMENT 51700MAP_2007_0F adskflex 1.000 permanent 3 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=UH ISSUED=15-jul-2006 SN=123-12345678 SIGN="1707 \

9EAC CBCB 2405 692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 \

5A1B 4A44 083A BE5F 3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E \

3EBD 0B48 4E75 193A DA82" SIGN2="004A FC90 AB47 3F6B 59BC \

6681 6971 A76A BA52 98E2 5671 26B3 0E78 791B 109F 0591 7DC3 \

F09F 4D8D 4FB7 E341 4A03 CD68 1D77 27F8 8555 9CF7 DEDD 9380"


Пример дополнительных параметров файла лицензий [Руководство по сетевому лицензированию Autodesk: ]

Пример комбинированного файла лицензий для различных версий продуктов Autodesk
Примеры файлов лицензий
Примеры пакетных файлов лицензий
Пример дополнительных параметров файла лицензий

Для продуктов Autodesk, которые поставляются в составе пакета продуктов, а также продаются отдельно, лицензии назначаются на основе порядка приоритетов, установленного в файле лицензий. Для таких продуктов в файле лицензий имеется информация, сходная с данными из приведенного ниже примера:

INCREMENT PLIST adskflex 1.000 permanent 1 \

VENDOR_STRING=A07:51600ACDLAND_2007_0F:52200CIV3D_2007_0F;B07:51900AMECH_PP_2007_0F:51300INVBUN_11_0F:51400INVPRO_11_0F07:51900AMECH_PP_2007_0F:51300INVBUN_11_0F:51400INVPRO_11_0F

SUPERSEDE ISSUED=15-jul-2006 SIGN="14C8 A29F BA92 C89A F132 \

BE66 0206 D8BE F9B7 3FB5 9229 FEB8 2E8D 995E EBB5 1B9E 0142 \

C933 9483 D0D0 CA94 6532 1CB5 37D7 03CD B085 7301 7484 CA71 \

2861" SIGN2="0B21 109E EED0 4863 A6E9 6A65 8C7B 6D0B 0B04 \

2F22 355F 433B 2D81 A540 1D45 55A1 DA71 4024 DA50 35E2 \

0089 3081 724E 860B A11F EBBE 3641 A1D5"


Примеры пакетных файлов лицензий [Руководство по сетевому лицензированию Autodesk: ]

Пример дополнительных параметров файла лицензий
Сведения о лицензиях
Пример пакетного файла лицензий для конфигурации с одним сервером
Примеры пакетных файлов лицензий

Компания Autodesk предлагает пользователям вариант с пакетным файлом лицензий, который дает возможность использовать пакет продуктов, скомпонованных и продаваемых вместе, при этом осуществляется контроль общего числа приобретенных лицензий.

В пакете лицензий пользователь получает один файл лицензий для запуска любого продукта из пакета на любом числе приобретенных рабочих мест.

Например, если пользователь приобрел 100 рабочих мест для трех продуктов Autodesk, он может использовать один файл лицензий для запуска трех продуктов из этого пакета в любой комбинации на рабочих местах, при этом количество рабочих мест может достигать 100.

Ниже приведены примеры пакетных файлов лицензий для конфигураций с одним сервером, с несколькими серверами, с резервным сервером, а также пример комбинированного файла для различных версий продуктов Autodesk.

Темы в этом разделе

  • Пример пакетного файла лицензий для конфигурации с одним сервером
  • Пример пакетного файла лицензий для конфигурации с несколькими серверами лицензий
  • Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий
  • Пример комбинированного файла лицензий для различных версий продуктов Autodesk


Пример пакетного файла лицензий для конфигурации с одним сервером [Руководство по сетевому лицензированию Autodesk: ]

Примеры пакетных файлов лицензий
Примеры пакетных файлов лицензий
Пример пакетного файла лицензий для конфигурации с несколькими серверами лицензий
Пример пакетного файла лицензий для конфигурации с одним сервером

Полный файл лицензий для конфигурации с одним сервером может выглядеть, например, следующим образом:

SERVER Server2 2a34567f90d3

USE_SERVER

VENDOR adskflex port=2080

PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="48400REVIT_6_0F\

51200ACD_2007_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \

ISSUED=15-jul-2006 SIGN="1707 9EAC CBCB 2405 692E 4A89 \

AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \

FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 98E2 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"

INCREMENT SERIES_1 adskflex 1.000 permanent 150 \

VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \

SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \

692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \

3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"


Пример пакетного файла лицензий для конфигурации с несколькими серверами лицензий [Руководство по сетевому лицензированию Autodesk: ]

Пример пакетного файла лицензий для конфигурации с одним сервером
Примеры пакетных файлов лицензий
Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий
Пример пакетного файла лицензий для конфигурации с несколькими серверами лицензий

Полный файл лицензий для конфигурации с несколькими серверами лицензий может выглядеть, например, следующим образом:

SERVER Server2 2a34567f90d3

USE_SERVER

VENDOR adskflex port=2080

PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="52600REVIT_9_0F \

51200ACD_2007_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \

ISSUED=15-jul-2006 SIGN="1707 9EAC CBCB 2405 692E 4A89 \

FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \

AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"

INCREMENT SERIES_1 adskflex 1.000 permanent 150 \

VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \

SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \

692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A \

3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"


Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий [Руководство по сетевому лицензированию Autodesk: ]

Пример пакетного файла лицензий для конфигурации с несколькими серверами лицензий
Примеры пакетных файлов лицензий
Пример комбинированного файла лицензий для различных версий продуктов Autodesk
Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий

Полный файл лицензий для конфигурации с резервными серверами лицензий может выглядеть, например, следующим образом:

SERVER Server1 1a34567c90d2 27005

SERVER Server2 2a34567f90d3 27005

SERVER Server3 3a34567b90d4 27005

USE_SERVER

VENDOR adskflex port=2080

PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="52500REVIT_9_0F \

51200ACD_2007_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \

ISSUED=15-jul-2006 SIGN="1707 9EAC CBCB 2405 692E 4A89 \

FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \

AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"

INCREMENT SERIES_1 adskflex 1.000 permanent 150 \

VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \

SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \

692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \

3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"


Пример комбинированного файла лицензий для различных версий продуктов Autodesk [Руководство по сетевому лицензированию Autodesk: ]

Пример пакетного файла лицензий для конфигурации с резервными серверами лицензий
Примеры пакетных файлов лицензий
Типы и виды лицензий
Пример комбинированного файла лицензий для различных версий продуктов Autodesk

В данном примере первые 50 заимствованных лицензий (51200ACD_2007_0F) продукта AutoCAD 2007 вычитаются в верхней строке Increment. Пятьдесят первая лицензия вычитается в строке Package:

SERVER Server1 1a34567c90d2 27005

USE_SERVER

VENDOR adskflex port=2080

INCREMENT 51200ACD_2007_0F adskflex 1.000 permanent 50 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=UH ISSUED=22-mar-2005 SN=123-12345678 \

SIGN=6E88EFA8D44C

PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="52600REVIT_9_0F \

51200ACD_2007_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \

ISSUED=15-jul-2006 SIGN="1707 9EAC CBCB 2405 692E 4A89 \

FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \

AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A 98E2 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"

INCREMENT SERIES_1 adskflex 1.000 permanent 150 \

VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \

SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \

692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A \

3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"

В данном примере первые 150 заимствованных лицензий (51200ACD_2007_0F) продукта AutoCAD 2007 вычитаются в строке Package/Increment. Сто пятьдесят первая лицензия вычитается в строке Increment:

SERVER Server1 1a34567c90d2 27005

USE_SERVER

VENDOR adskflex port=2080

PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="52600REVIT_9_0F \

48800ACD_2006_0F 46400INVBUN_9_0F" OPTIONS=SUITE SUPERSEDE \

ISSUED=10-mar-2005 SIGN="1707 9EAC CBCB 2405 692E 4A89 \

FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \

30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"

INCREMENT SERIES_1 adskflex 1.000 permanent 150 \

VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \

SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \

692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 \

3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \

SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \

5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \

CD68 1D77 27F8 8555 9CF7 DEDD 9380"

INCREMENT 48800ACD_2006_0F adskflex 1.000 permanent 50 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=UH ISSUED=22-apr-2005 SN=123-12345678 \

SIGN=6E88EFA8D44C


Типы и виды лицензий [Руководство по сетевому лицензированию Autodesk: ]

Пример комбинированного файла лицензий для различных версий продуктов Autodesk
Сведения о лицензиях
Тактовый сигнал
Типы и виды лицензий

Autodesk поддерживает динамическое изменение типа и вида лицензий. Это означает, что, купив лицензию определенного типа и вида, в дальнейшем пользователь может изменить тип и вид лицензий без переустановки продукта Autodesk.

По условиям использования лицензии делятся на следующие типы:

  • Коммерческая. Лицензия на продукт, приобретенный коммерческим путем.
  • Не для перепродажи. Лицензия на продукт, полученный некоммерческими способами.
  • Для учебных заведений. Лицензии этого типа предназначены для учебных заведений.
  • Для студентов. Лицензии для студентов, использующих продукты Autodesk в академических целях.

По своему поведению лицензии бывают следующих видов:

  • Постоянная. Предполагает использование продукта Autodesk в течение неограниченного срока.
  • Временная с возможностью продления. Лицензии данного вида позволяют использовать продукт Autodesk в течение ограниченного промежутка времени. Действие таких лицензий можно продлить в любой момент.
  • Ограниченная. Лицензии данного вида позволяют использовать продукт Autodesk в течение ограниченного промежутка времени. Продлить действие таких лицензий нельзя.


Тактовый сигнал [Руководство по сетевому лицензированию Autodesk: ]

Типы и виды лицензий
Сведения о лицензиях
Инструменты сетевого лицензирования
Тактовый сигнал

Во время работы продукт Autodesk регулярно связывается с сервером лицензий через определенные интервалы времени, используя метод связи, который называют “тактовым сигналом“. При отсутствии на каком-либо такте соединения сервер повторно пытается установить связь. Если это не удается, пользователь получает сообщение об ошибке лицензирования.

Если продукт прекратил работу из-за отсутствия соединения с сервером, требуется закрыть его, а затем запустить заново. Если проблемы, вызвавшие сбой в регулярном соединении, устранены и имеются свободные лицензии, программа заново начнет работу.


Инструменты сетевого лицензирования [Руководство по сетевому лицензированию Autodesk: ]

Тактовый сигнал
Установка Autodesk Network License Manager
Инструменты сетевого лицензирования

В этой главе описана установка и настройка диспетчера сетевых лицензий в сети, а также установка и использование программы активации сетевой лицензии.

Темы в этом разделе

  • Установка Autodesk Network License Manager
  • Установка программы активации сетевой лицензии
  • Использование программы "Network License Activation" (Активации сетевой лицензии)
  • Получение имени и идентификатора хоста вручную
  • Настройка сервера лицензий
  • Остановка работы и перезапуск сервера лицензий
  • Настройка и использование файла параметров
  • Удаление Network License Manager


Установка Autodesk Network License Manager [Руководство по сетевому лицензированию Autodesk: ]

Инструменты сетевого лицензирования
Инструменты сетевого лицензирования
Установка программы активации сетевой лицензии
Установка Autodesk Network License Manager

Network License Manager можно установить как до, так и после сетевой установки основного продукта. Сетевые приложения могут быть установлены в любой последовательности, при этом для всех приложений должен быть обеспечен доступ к серверу лицензий.

Если на компьютере имеется более ранняя версия Диспетчера сетевых лицензий, следует обновить ее, установив Диспетчер сетевых лицензий Autodesk в ту же папку, где хранится старая версия. При выборе другой папки на компьютере будут одновременно установлены две версии Network License Manager.

Для установки Autodesk Network License Manager

  1. В обозревателе диска открыть вкладку "Install" (Установка).
  2. На вкладке "Установка" выбрать "Сетевое развертывание".
  3. В группе "Установка компонентов лицензирования" нажать ссылку "Network License Manager".
  4. На странице "Autodesk Network License Manager Setup" (Настройка Autodesk Network License Manager) нажать "Next" (Далее).
  5. На странице "License Agreement" (Лицензионный договор) прочесть лицензионный договор, установить флажок "I Accept" (Принимаю) и нажать "Далее".
    ЗамечаниеВ случае несогласия с условиями договора нужно нажать кнопку "Cancel" (Отмена) для отмены установки.
  6. На странице "Destination Folder" (Папка для установки) принять заданную по умолчанию папку (C:\Program Files\Autodesk Network License Manager\) или нажать кнопку "Browse" (Обзор) для указания другой папки для установки. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажать "Next" (Далее).
    Предупреждение Network License Manager не может быть установлен на сетевом диске. Папка для установки Network License Manager должна быть локальной. Необходимо явно указывать букву имени диска; формат универсального именования (UNC) здесь не подходит.
  7. На странице "Ready to Install the Application" (Начало установки) нажать кнопку "Next" (Далее), чтобы перейти к копированию файлов на диск.
  8. Нажать "Finish" (Готово).


Установка программы активации сетевой лицензии [Руководство по сетевому лицензированию Autodesk: ]

Установка Autodesk Network License Manager
Инструменты сетевого лицензирования
Использование программы "Network License Activation" (Активации сетевой лицензии)
Установка программы активации сетевой лицензии

Программа активации сетевой лицензии предназначена для получения файлов лицензий через Интернет.

Установка программы "Network License Activation" (Активации сетевой лицензии)

  1. В обозревателе диска открыть вкладку "Install" (Установка).
  2. На вкладке "Установка" выбрать "Сетевое развертывание".
  3. В группе " Install the Network License Components" (Установка компонентов лицензирования) кнопкой мыши нажать ссылку "Install the Network License Components" (Программа активации сетевой лицензии).
  4. На странице "Network License Activation Setup" (Установка программы активации сетевой лицензии)[имя продукта Autodesk]" нажать "Next" (Далее).
  5. На странице "License Agreement" (Лицензионный договор) прочитать лицензионный договор, нажать кнопку "I accept" (Принимаю), а затем кнопку "Next" (Далее).
    ЗамечаниеВ случае несогласия с условиями договора нужно нажать кнопку "Cancel" (Отмена) для отмены установки.
  6. На странице "Destination Folder" (Папка для установки) принять заданную по умолчанию папку или нажать кнопку "Browse" (Обзор) для указания иной папки для установки. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажать "Next" (Далее).
  7. На странице "Ready to Install the Application" (Начало установки) нажать кнопку "Next" (Далее), чтобы перейти к копированию файлов на диск.
  8. Нажать "Finish" (Готово).


Использование программы "Network License Activation" (Активации сетевой лицензии) [Руководство по сетевому лицензированию Autodesk: ]

Установка программы активации сетевой лицензии
Инструменты сетевого лицензирования
Получение имени и идентификатора хоста вручную
Использование программы "Network License Activation" (Активации сетевой лицензии)

Программа активации сетевой лицензии позволяет получать лицензии через Интернет. Кроме того, эта утилита отвечает за регистрацию программного продукта, обеспечивает автоматическое формирование сообщений электронной почты в случае отсутствия возможности получить лицензию через Интернет, а также автоматически сохраняет и перемещает файлы лицензий.

Перед тем как использовать программу активации сетевой лицензии для получения файла лицензий, необходимо убедиться в наличии следующей информации:

  • Сведения о сервере лицензий, включая имя (имена) хоста и идентификатор(ы) хоста
  • Серийный номер предыдущей версии продукта (для обновлений)
  • Доступ к папке для сохранения файлов лицензий

Использование программы "Network License Activation" (Активации сетевой лицензии)

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий" [image] [Наименование продукта Autodesk] "Активация сетевой лицензии".
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) ознакомиться с принципами работы утилиты и системными требованиями к ее использованию. Затем нажать "Next" (Далее).
  3. На странице "Server Information" (Сведения о сервере) ввести серийный номер продукта.
    Замечание В случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
  4. В разделе "License Server Model" (Модель сервера лицензий) выбрать модель сервера лицензий. Чтобы узнать подробнее об имеющихся вариантах модели, можно воспользоваться кнопкой с вопросительным знаком.
  5. В поле "Server Host Name" (Имя хоста) ввести имя хоста сервера или воспользоваться кнопкой [...] для получения имен из сети.
  6. Для каждого имени хоста, введенного на предыдущем этапе, заполнить поле "Host ID" (ID хоста) с помощью кнопки " Lookup" (Выбрать), или ввести значения вручную.
    Замечание Если на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Для того чтобы определить, какой из адаптеров соответствует физическому устройству, нужно ввести ipconfig /all в командной строке Windows и просмотреть информацию в поле "Описание", расположенном над каждым физическим адресом. Если физических сетевых адаптеров несколько, можно использовать любой из них; для этого необходимо, чтобы его имя выводилось в список командой ipconfig /all. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями не годятся.
  7. Если в пункте 4 было выбрано "Distributed Server" (Распределенный сервер), появляется поле "Seats" (Рабочие места). В поле "Seats" (Рабочие места) требуется ввести количество рабочих мест, обслуживаемых каждым сервером лицензий, а затем нажать кнопку "Next" (Далее).
  8. На странице "Confirm Server Information" (Подтвердить информацию сервера) проверить введенную вами информацию сервера и нажать кнопку "Next" (Далее).
  9. Если отобразится страница "Register and License Your Autodesk Product" (Регистрация продукта Autodesk и получение лицензии на него), выполнить следующие действия, после чего нажать кнопку "Next" (Далее).
    • Для параметра "In the This Product Is To Be Registered To" (Регистрация продукта выполняется на) установить значение "Company" (Организация) или " Individual" (Частное лицо).
    • В поле "Select Country or Region" (Выберите страну или территорию) выбрать страну или территорию проживания.
    • Установить опцию "Is This an Upgrade" (Обновляется ли продукт с прежней версии) в положение "Yes" (Да) или "No" (Нет).
  10. Если отобразится страница "Registration Information" (Регистрационные данные) ввести пользовательские регистрационные данные и нажать "Next" (Далее).
  11. Если отобразится страница "Confirm Information" (Подтверждение данных) проверить регистрационные данные и нажать "Next" (Далее).
  12. Если отобразится страница "Connecting" (Связь с Интернетом) нажать "Next" (Далее), чтобы подключиться к Интернету и получить сетевую лицензию.
  13. На странице "Полученные лицензии" ввести место для сохранения файла лицензии в поле "Сохранить файл лицензий для [computer name] в" или найти его на диске с помощью кнопки "Обзор".
    Замечание Рекомендуется сохранять файл лицензий там же, где установлен диспетчер сетевых лицензий.
  14. Если уже имеется файл лицензий от другого продукта Autodesk, выбрать одну из следующих опций:
    • Вставить информацию о новой лицензии в него. Добавление сведений о новой лицензии в существующий файл лицензий.
    • Заменить существующий файл лицензий. Полная замена содержимого существующего файла лицензий сведениями о новой лицензии. Этот параметр следует выбирать только в том случае, если все остальные лицензии в файле действительно больше не нужны.
  15. Нажать "Next" (Далее).
  16. На странице "License Activation Successful" (Активация лицензии успешно выполнена) нажать кнопку "Print" (Печать), чтобы вывести информацию о лицензии на печать, либо нажать "Done" (Готово) для завершения групповой операции и выхода из программы активации сетевой лицензии.


Получение имени и идентификатора хоста вручную [Руководство по сетевому лицензированию Autodesk: ]

Использование программы "Network License Activation" (Активации сетевой лицензии)
Инструменты сетевого лицензирования
Настройка сервера лицензий
Получение имени и идентификатора хоста вручную

При отсутствии возможности использовать программу активации сетевой лицензии для получения имени и кода хоста сервера можно получить данную информацию вручную. Для генерации файла лицензий компании Autodesk требуется имя хоста, идентификатор хоста и серийный номер продукта.

Для получения информации вручную можно использовать командную строку Windows или запустить утилиту lmtools.exe . Утилиту lmtools.exe нельзя запускать на удаленной рабочей станции.

Для получения имени и идентификатора хоста с использованием командной строки Windows

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Принадлежности" [image] "Приглашение к вводу команд".
  2. В командной строке Windows ввести следующую команду и нажать ENTER:

    ipconfig /all

  3. Найти строку "Имя хоста" и ввести имя хоста.
  4. Найти строку "Физический адрес". Записать физический адрес, игнорируя дефисы в нем. Это и будет двенадцатисимвольный идентификатор хоста.
    ЗамечаниеЕсли на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Для того чтобы определить, какой из адаптеров соответствует физическому устройству, нужно в командной строке Windows ввести ipconfig /all и просмотреть информацию в поле "Описание", расположенном над каждым физическим адресом. Если сетевых адаптеров несколько, можно использовать любой из них. Следует, однако, удостовериться, что он правильно установлен и находится в рабочем состоянии. Такие устройства, как VPN- и PPP-адаптеры, а также модемы, не поддерживаются.
  5. Закрыть командную строку Windows.

Для получения имени и идентификатора хоста с помощью lmtools.exe

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий Autodesk" [image] LMTOOLS.
  2. В окне программы Lmtools перейти на вкладку "Systems Settings" (Настройки системы).
  3. На вкладке "Systems Settings" (Настройки системы) найти поле "Computer/Hostname" (). Скопировать имя хоста и вставить информацию в текстовый редактор.
  4. Найти поле "Ethernet Address" (Адрес Ethernet узла сервера). В поле "Ethernet Address" отображается идентификатор хоста. Он должен состоять из двенадцати символов. Записать информацию. Если длина полученного кода слишком велика, следует записать только первые двенадцать символов.
    Замечание Если на сервере установлено несколько адаптеров Ethernet, необходимо выбрать тот из них, который соответствует физическому устройству.
  5. Закрыть lmtools.exe.


Настройка сервера лицензий [Руководство по сетевому лицензированию Autodesk: ]

Получение имени и идентификатора хоста вручную
Инструменты сетевого лицензирования
Остановка работы и перезапуск сервера лицензий
Настройка сервера лицензий

Настройка сервера лицензий осуществляется таким образом, чтобы можно было управлять лицензиями на продукт Autodesk. Для настройки параметров сервера используется утилита lmtools.exe.

Для настройки параметров сервера лицензий

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий" [image] LMTOOLS.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы Lmtools установить переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Перейти на вкладку "Config Services" (Настроить службу).
  4. На вкладке "Config Services" (Настроить службу) в списке "Service Name" (Имя службы) выбрать службу или выполнить одно из следующих действий
    • Убедиться, что в списке выбрана именно та служба, которую предполагается использовать для управления лицензиями.
    • Если список пуст, ввести имя службы, которую предполагается использовать для управления лицензиями.
    ЗамечаниеЕсли установлены несколько программных продуктов различных поставщиков, которые для управления лицензиями используют технологию FLEXlm®, список "Наименование службы" содержит несколько служб.
  5. В поле "Path to Lmgrd.exe File" (Путь к файлу Lmgrd.exe)задать путь к демону Network License Manager (lmgrd.exe), или найти его с помощью кнопки "Browse" (Обзор).

    По умолчанию этот демон устанавливается в папку \Program Files\Autodesk Network License Manager.

  6. В поле "Path to the License File" (Путь к файлу лицензий) ввести путь к файлу лицензий или найти его с помощью кнопки "Browse" (Обзор).
  7. В поле "Path to the Debug Log File" (Путь к файлу отладочного журнала) ввести путь, по которому формируется отладочный журнал, или найти с помощью кнопки "Browse" (Обзор) существующий журнал.
  8. Для запуска lmgrd.exe в качестве службы установить флажок "Use Services".
  9. Для автоматической загрузки lmgrd.exe при запуске системы установить флажок "Start Server at Power Up".
  10. Для сохранения настроек с именем, заданным в пункте 4, нажать кнопку "Save Service" (Сохранить службу). Нажать "Да".
  11. Перейти на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  12. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) выполнить одно из следующих действий:
    • Если службы для продуктов Autodesk еще не созданы, нажать кнопку "Start Server" (Запустить сервер) для запуска сервера лицензий.
    • Если служба для продукта Autodesk уже создана и запущена, нажать кнопку "ReRead License File" (Прочитать еще раз файл лицензий) для обновления Диспетчера сетевых лицензий и всех изменений файла лицензий или параметров.

      Сервер лицензий запускается и готов обрабатывать запросы клиентов.

  13. Закрыть lmtools.exe.


Остановка работы и перезапуск сервера лицензий [Руководство по сетевому лицензированию Autodesk: ]

Настройка сервера лицензий
Инструменты сетевого лицензирования
Настройка и использование файла параметров
Остановка работы и перезапуск сервера лицензий

Для внесения системных изменений в работу сервера лицензий требуется остановить сервер лицензий. После того как все изменения внесены, необходимо перезапустить сервер лицензий.

Для остановки сервера лицензий

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий Autodesk" [image] LMTOOLS.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы Lmtools установить переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Выбрать имя службы того сервера лицензий, который требуется запустить вручную.
  4. Перейти на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  5. Для остановки сервера лицензий нажать кнопку "Stop Server" (Остановить сервер) на вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  6. Закрыть lmtools.exe.

Для перезапуска сервера лицензий

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий Autodesk" [image] LMTOOLS.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы Lmtools установить переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Выбрать имя службы того сервера лицензий, который требуется запустить вручную.
  4. Перейти на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  5. Для перезапуска сервера лицензий нажать кнопку "Start Server" (Запустить сервер) на вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).


Настройка и использование файла параметров [Руководство по сетевому лицензированию Autodesk: ]

Остановка работы и перезапуск сервера лицензий
Инструменты сетевого лицензирования
Создание отчета об использовании лицензий
Настройка и использование файла параметров

С помощью файла параметров можно настроить параметры, необходимые для управления лицензиями на всех настраиваемых серверах лицензий. Параметры, заданные в этом файле, читаются файлом лицензий и выполняются программой Lmgrd.

Если нужно иметь лицензии одного вида на нескольких или сразу на всех серверах лицензий, следует сохранить одинаковый файл параметров на каждом сервере. Если на разных серверах нужно иметь различные виды лицензий, следует создать файл параметров для каждого вида лицензий отдельно. Каждый файл параметров должен быть сохранен на сервере, на котором будут храниться лицензии определенного вида.

ЗамечаниеДля того чтобы произведенные в файле параметров изменения вступили в силу, необходимо сохранить файл параметров, а затем запустить lmtools.exe для перезапуска файла лицензий.

С помощью файла параметров можно производить следующие действия:

  • Создание отчета об использовании лицензий
  • Настройка параметров заимствования лицензий
  • Настройка параметров тайм-аута лицензий

Файл параметров имеет следующий вид:

REPORTLOG=c:\test\report.rl

BORROW_LOWWATER Autodesk_f1 3

TIMEOUT Autodesk_f1 7200

Существует также возможность настройки дополнительных параметров, таких как резервирование лицензии, ограничение использования лицензии и определение групп пользователей. Более подробную информацию о дополнительных настройках файла параметров см. в документации по FLEXlm, находящейся в папке Program Files\Autodesk Network License Manager\ Docs\FlexUser.

Для создания файла параметров

  1. Открыть текстовый редактор, ввести желаемые параметры и сохранить документ под именем adskflex.opt в той же папке, в которой был сохранен файл лицензий.
    ЗамечаниеСохранять файл следует с расширением .opt. Расширение .txt, используемое текстовым редактором по умолчанию, не распознается программой Network License Manager.
  2. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий Autodesk" [image] LMTOOLS.
  3. В программе lmtools перейти на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) и выбрать "ReRead License File" (Прочитать файл лицензий еще раз).
  4. Закрыть lmtools.exe.

Темы в этом разделе

  • Создание отчета об использовании лицензий
  • Настройка параметров заимствования лицензий
  • Настройка параметров тайм-аута лицензий


Создание отчета об использовании лицензий [Руководство по сетевому лицензированию Autodesk: ]

Настройка и использование файла параметров
Настройка и использование файла параметров
Настройка параметров заимствования лицензий
Создание отчета об использовании лицензий

С помощью файла параметров можно создать файл отчета о лицензиях, который может быть использован в SAMreport-Lite.

Для создания отчета об использовании лицензий

  1. В текстовом редакторе открыть файл adskflex.opt.
  2. В файле параметров введите строку со следующим синтаксисом (REPORTLOG вводится прописными буквами, как показано ниже):

    REPORTLOG [+]путь_к_файлу_отчета

    Например, конструкция REPORTLOG +"c:\Мои документы\report.rl" означает, что файл отчета с именем report.rl находится в папке c:\Мои документы.

    Замечание Если имя пути содержит пробелы, оно должно заключаться в кавычки.

    Знак “[+]“ в конструкции REPORTLOG означает, что новые записи добавляются в файл отчета, а не заменяются при каждом перезапуске Диспетчера сетевых лицензий. Рекомендуется использовать эту опцию для сохранения всех записей.


Настройка параметров заимствования лицензий [Руководство по сетевому лицензированию Autodesk: ]

Создание отчета об использовании лицензий
Настройка и использование файла параметров
Настройка параметров тайм-аута лицензий
Настройка параметров заимствования лицензий

Если продукт Autodesk поддерживает возможность заимствования лицензий, для настройки процесса заимствования можно использовать файл параметров лицензий. Например, там можно задать максимальное количество лицензий, которые не могут быть одновременно заимствованы из сети. Кроме того, можно определить, какие пользователи имеют право на заимствование лицензии продукта Autodesk. Лицензии заимствуются на количество пользователей, а не на количество компьютеров.

ЗамечаниеЕсли установленный на компьютере продукт Autodesk поддерживает заимствование лицензий и лицензии заимствуются с пула резервного сервера лицензий, после останова Network License Manager необходимо перезапустить сервер лицензий.

По окончании периода заимствования заимствованная лицензия автоматически отключается на компьютере пользователя и снова становится доступной на сервере лицензий. Пользователь также имеет возможность вернуть лицензию до окончания срока ее заимствования.

Для настройки параметров заимствования лицензий

  1. В файле параметров ввести строку со следующим синтаксисом (BORROW_LOWWATER вводится прописными буквами, как показано ниже):

    BORROW_LOWWATER код_продукта n

    В строке BORROW “код_продукта“ представляет собой имя продукта в файле лицензий, а “n“ - число лицензий, которое не допускается заимствовать.

    Например, строка BORROW_LOWWATER Autodesk_f1 3 означает, что для продукта Autodesk_f1 с сервера лицензий нельзя заимствовать три лицензии.

  2. Далее ввести строку со следующим синтаксисом (MAX_BORROW_HOURS вводится прописными буквами, как показано ниже):

    MAX_BORROW_HOURS код_продукта n

    В данной строке “n“ – это количество часов действия заимствованной лицензии.

    Например, строка MAX_BORROW_HOURS Autodesk_f1 360 означает, что для продукта Autodesk_f1 лицензии могут заимствоваться на 360 часов (т.е. 15 дней).

    ЗамечаниеЛицензии заимствуются на количество часов, кратное 24. Не кратное числу 24 количество часов подвергается округлению. Например, 365 округляется до 360 часов, или 15 дней.

Дополнительную информацию о заимствовании лицензий см. в документации по FLEXlm, находящейся в папке Program Files\Autodesk Network License Manager\Docs\FlexUser.

Замечание Для заимствования лицензии в продукте Autodesk следует выбрать меню "Сервис" [image] "Заимствование лицензии" или ввести команду заимлиц в командной строке продукта Autodesk. Справочные сведения можно получить в окне команды заимствования лицензий [имя продукта Autodesk], а также в файле \Program Files\[имя продукта Autodesk]\Help\[имя продукта Autodesk]_brw.chm.


Настройка параметров тайм-аута лицензий [Руководство по сетевому лицензированию Autodesk: ]

Настройка параметров заимствования лицензий
Настройка и использование файла параметров
Удаление Network License Manager
Настройка параметров тайм-аута лицензий

В файле параметров можно задать тайм-аут лицензий, для того чтобы определить временной интервал, по истечении которого неактивная лицензия отзывается сервером лицензий. При установке этого флага в файле параметров лицензия возвращается на сервер лицензий, если продукт не используется на рабочей станции дольше времени, заданного тайм-аутом.

Если лицензия была потеряна из-за превышения времени тайм-аута, при возврате пользователя к работе с продуктом будет предпринята попытка получить новую лицензию. Если доступных лицензий нет, пользователь получает возможность сохранить свою работу перед закрытием продукта.

Для настройки параметров тайм-аута лицензий

  • В файле параметров ввести строку со следующим синтаксисом (TIMEOUT вводится прописными буквами, как показано ниже):

    TIMEOUT код_продукта n

    В строке TIMEOUT “код_продукта” является наименованием продукта (см. в строке INCREMENT в файле лицензий), а “n” – число секунд до повторного запроса неактивной лицензии сервером лицензий.

    Например, строка TIMEOUT Autodesk_f1 7200 означает, что для продукта Autodesk_f1 тайм-аут составляет 7200 секунд, или два часа.

Дополнительную информацию о тайм-ауте лицензий см. в документации по FLEXlm, находящейся в папке Program Files\Диспетчер сетевых лицензий Autodesk\Docs\FlexUser.


Удаление Network License Manager [Руководство по сетевому лицензированию Autodesk: ]

Настройка параметров тайм-аута лицензий
Инструменты сетевого лицензирования
Словарь терминов
Удаление Network License Manager

Network License Manager можно удалить с сервера лицензий. После удаления Network License Manager лицензии становятся недоступными для пользователей.

Для удаления Network License Manager

  1. Выбрать меню "Пуск" (Windows) [image] "Все программы" (или "Программы") [image] "Autodesk" [image] "Диспетчер сетевых лицензий Autodesk" [image] LMTOOLS.
  2. На вкладке "Service/License File" (Службы/Файлы лицензии)программы Lmtools установить переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. В разделе "License Server Model" (Модель сервера лицензий) выбрать модель сервера лицензий.
  4. Для остановки сервера лицензий нажать кнопку "Stop Server" (Остановить сервер) на вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  5. Закрыть lmtools.exe.
  6. На "Панели управления" Windows произвести двойное нажатие значка "Установка и удаление программ".
  7. В окне "Установка и удаление программ" выбрать Network License Manager, а затем нажать кнопку "Исключить".
  8. Если потребуется, перезагрузить компьютер.
Замечание Созданные в ходе работы Network License Manager файлы должны быть удалены вручную; это относится, например, к файлам журнала, лицензий и параметров. При удалении Network License Manager эти файлы автоматически не удаляются.


Словарь терминов [Руководство по сетевому лицензированию Autodesk: ]

Удаление Network License Manager
Словарь терминов
ADSKFLEX_LICENSE_FILE

Переменная среды, использующаяся в конфигурации с несколькими серверами лицензий для определения сервера, к которому рабочая станция должна обратиться за лицензией.

adskflex.exe

Демон поставщика Autodesk, использующийся в технологии лицензирования FLEXlm. Демон поставщика постоянно следит за выданными лицензиями Autodesk и рабочими станциями, на которых они используются.

FLEXlm

Предоставленная компанией Macrovision Corporation технология, использующаяся для управления лицензиями на продукты Autodesk.

JRE (Java Runtime Environment)

Программа, требующаяся для запуска Java-программ. Эту программу следует устанавливать вместе с SAMreport-Lite.

licpath.lic

Файл, использующийся в конфигурациях с одним сервером и с резервными серверами для определения сервера лицензий FLEXlm, к которому обращается рабочая станция. Файл Licpath.lic находится в корневой папке устанавливаемого программного продукта.

lmgrd.exe

Демон диспетчера лицензий. Этот демон осуществляет первичное соединение с приложением, а затем устанавливает соединение с демоном поставщика (adskflex.exe).

lmtools.exe

Утилита управления технологией лицензирования FLEXlm, обладающая графическим пользовательским интерфейсом. (Lmutil.exe является версией данной утилиты с интерфейсом командной строки)

lmutil.exe

Утилита управления технологией лицензирования FLEXlm с интерфейсом командной строки. (Lmtools.exe является версией этой утилиты с графическим интерфейсом пользователя.)

Network License Manager

Технология, используемая Autodesk для управления сетевыми лицензиями.

SAMreport-Lite

Версия программы SAMreport, разработанной компанией Macrovision Corporation. Программа SAMreport-Lite включена в пакет поставки продуктов Autodesk и имеется на компакт-диске продукта.

адрес Ethernet (Ethernet address)

См. идентификатор хоста.

демон (daemon)

Постоянно работающая фоновая программа. Демон обрабатывает сделанные компьютером запросы и передает их другим программам или процессам. В диспетчере сетевых лицензий используются два демона: демон поставщика (adskflex.exe) и демон диспетчера лицензий (lmgrd.exe).

демон поставщика (vendor daemon)

См. adskflex.exe.

дерево запуска (runtree)

Местоположение программных файлов продукта Autodesk, например acad.exe.

заимствованная лицензия (borrowed license)

Лицензия, позволяющая в течение ограниченного периода времени работать с продуктом Autodesk без необходимости в приобретении отдельной лицензии или без доступа к серверу лицензий. В предыдущих версиях продуктов Autodesk для этого использовался переключатель конфигурации лицензии.

идентификатор хоста (host ID)

Уникальный физический адрес сетевого адаптера. Также известен как адрес Ethernet или физический адрес.

имя хоста (host name)

TCP/IP-имя, присваиваемое компьютеру. В технологии FLEXlm имя хоста используется в качестве параметра. Имя хоста должно отличаться от имени NetBIOS (имени сервера).

конфигурация с несколькими серверами (distributed server)

Конфигурация с несколькими серверами лицензий, в которой для управления распределением лицензий используется несколько серверов. Каждый сервер имеет собственный уникальный файл лицензий и определенное количество лицензий. При сбое одного из серверов распределенного пула лицензии на остальных серверах остаются доступными.

конфигурация с резервными серверами (redundant server)

Конфигурация, в которой для управления лицензиями используется три сервера. Серверы в этой конфигурации имеют общий файл и пул лицензий. В этой конфигурации выдача лицензий не прекращается, если функционируют хотя бы два из этих трех серверов.

мастер-демон (master daemon)

См. lmgrd.exe.

отчет об использовании лицензий (report log file)

Файл, используемый FLEXlm и SAMreport-Lite. Этот файл предоставляет информацию об использовании сетевых лицензий. Файл отчета создается при участии файла параметров.

переключатель конфигурации лицензии (license configuration switcher)

См. заимствованная лицензия.

период неактивности (idle)

Период, в течение которого продукт остается неактивным, в результате чего сервер лицензий отзывает лицензию. Продукт может считаться неактивным по ряду причин например, если в течение временного периода, заданного в файле параметров, внутри продукта не было совершено ни одного нажатия клавиши или нажатия кнопки мыши или в течение этого времени не выполнялась ни одна команда, LISP-выражение, макрос меню или пакетный файл. См. также тайм-аут лицензий.

Программа активации сетевой лицензии (Network License Activation utility)

Утилита, позволяющая сетевым администраторам получать лицензии и авторизовывать сетевые версии продуктов Autodesk через Интернет.

рабочая станция (workstation)

Подключенный к сети компьютер, на котором работает один пользователь.

развертывание (deployment)

Набор файлов и папок, созданный на сервере и использующийся рабочими станциями для установки программ Autodesk.

сервер лицензий (license server)

Сервер, на котором установлен Network License Manager.

сетевая установка (network license installation)

Вариант установки, при котором Network License Manager устанавливается и запускается на сервере. Network License Manager необходимо установить и настроить до того, как пользователи начнут работать с продуктом Autodesk.

тайм-аут лицензий (license timeout)

Параметр, позволяющий задавать временной интервал, по истечении которого неактивные лицензии автоматически возвращаются на сервер и становятся вновь доступными для использования.

тактовый сигнал (heartbeat signal)

Метод связи, использующийся для обмена информацией между Network License Manager и рабочей станцией для подтверждения того, что рабочая станция доступна и на ней производится активный сеанс работы с продуктом Autodesk.

файл журнала отладки (debug log file)

Файл, который FLEXlm использует для записи всех действий (таких как ошибки лицензирования или запуск и останов сервера), происходящих во время подключений диспетчером сетевых лицензий к рабочей станции.

файл лицензий (license file)

Файл, использующийся FLEXlm для управления количеством компьютеров, способных пользоваться лицензией. Этот файл должен быть в простом текстовом формате с кодировкой ASCII.

файл параметров (Options file)

Файл, используемый FLEXlm для настройки параметров, необходимых для управления лицензиями, например, таких как резервирование лицензий и создание файлов отчета об использовании лицензий с помощью SAMreport-Lite.

физический адрес (physical address)

См. идентификатор хоста.


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!